Schlagwort-Archive: cyberJack RFID standard

Moneyplex und Chipkartenleser unter openSuSE 12.3 (gelöst)

Seit letzten Sonntag funktionierte nach einem Update das Zusammenspiel von Moneyplex und dem Kartenleser nicht mehr. Meine Versuche es mit einem anderen Repository von /security:/chipcard waren leider nicht erfolgreich. Auch ein Schwenk auf das Factory Repo half nicht. Heute hatte ich einen Mail von Jörg, mit der Lösung. Es reicht ein Downgrad von pcsc-cyberjack auf die Version 3.99.5final.SP03-6.1.1.x86_64. Diese befindet sich im openSUSE-12.3-Oss Repository.

Wenn Moneyplex nicht läuft, reichen zwei Befehle, um das Problem zu fixen:

zypper in –oldpackage pcsc-cyberjack-3.99.5final.SP03-6.1.1
rcpcscd restart

Ein anschließendes zypper ps sollte No processes using deleted files found. melden.

Herzlichen Dank für den Tipp und ein schönes Wochenende

Thomas

Update 09. Februar 2014: Siehe auch Moneyplex und Card Reader nach Installation von openSUSE 13.1. Hier hilft die Installation der Treiber und ein Downgrade auf ein Paket von REINER SCT für die openSUSE 12.3, da es noch kein Paket für die 13.1 gibt.

Moneyplex und Chipkartenleser unter openSuSE 12.3

Update 26.10.2013: Lösung siehe hier.

Der Zugriff auf die Chipkarte war nicht erfolgreich. Perform Verification: Der Chipkartenleser kann nicht angesprochen werden.
Der Zugriff auf die Chipkarte war nicht erfolgreich.
Perform Verification: Der Chipkartenleser kann nicht angesprochen werden.

Nachdem es sehr lange – für Moneyplex Zeiten – gut gegangen ist, gibt es mit dem letzten Update der Chipkartenleser Software wieder Fehler. Nur sind diese Fehler ganz anderer Art als bisher. Das System erkennt den Chipkartenleser, der Befehl cyberjack läuft ohne Fehlermeldung durch, Moneyplex erkennt den Chipkartenleser und ob eine Chipkarte eingelegt ist beim Anmelden, in den Einstellungen und der Test ist auch erfolgreich. Wenn ich für den Kontenabruf die falsche Karte einstecke, erkennt Moneyplex dies auch und fordert die richtige Karte an. Nur, wenn dann die richtige Karte im Leser steckt, dann gibt es keinen Chipkartenleser mehr.

Jetzt bin ich ratlos. Bis der Fehler gefunden ist, wird die Überweisung wohl noch ein paar Tage warten müssen. Wie immer ärgerlich.

Update 24.10.2013: Die Antwort von Matrica war wenig hilfreich. Den Dämon für den Kartenlesen habe ich mehrfach gestartet. Auch habe ich mich an die Installationsanleitung gehalten. Es lief vor dem Update. Ich fürchte, der Fehler liegt im Update des Repositories vom 20. Oktober. Leider habe ich die älteren Pakete nicht mehr. Im Moment sollte man die Finger von einem Update lassen.

Sie haben nicht das richtige Sicherheitsmedium eingelegt.
Sie haben nicht das richtige Sicherheitsmedium eingelegt.
Es befindet sich keine Chipkate im Lesegerät.
Es befindet sich keine Chipkate im Lesegerät.