Server neu installiert

Heute habe ich diesen Server neu installiert. Das lange hinausgezögerte Upgrade von OpenSUSE 12.3 auf OpenSUSE 13.1 war endlich fällig. Leider unterstützt STRATO noch nicht die Version OpenSUSE 13.2, so dass cih sicher in absehbarer Zeit wieder Hand anlegen muss.

Trotz der Vorbereitung in einer virtuellen Maschine auf dem heimischen PC gab es einige Hürden zu überwinden. Mein Verhältbnis zu Postfix hat wieder etwas gelitten. Aber jetzt bin ich wieder per E-Mail erreichbar. Dafür Freunde ich mich mit Dovecot immer mehr an. In den nächsten Tagen werde ich im SSL/TLS beibringen – oder zuerst mir.

Auch der Apache2 bedarf einiger Nacharbeit, damit alle Module, die ich nutze hier laufen. Zu allem Überfluss ändern sich auch noch die Namen und Orte der Module, wenn die 64-Bit Version statt der 32-Bit installiert wird.

Gute Nacht

Moneyplex und Card Reader nach Installation von openSUSE 13.1 (2)

Gestern habe ich über die Probleme von Moneyplex und meinem Kartenleser nach der Installation von ooenSUSE 13.1 berichtet. In einer E-Mail hatte ich REINER SCT darauf hingewiesen, dass es hier Problem gibt und das auf ihren Seiten ein aktuelles Paket für openSUSE 13.1 fehlt. Hier der Kern der Antwort, die immerhin kein 24 Stunden benötigte:

Für openSUSE bieten wir keine vorgefertigten Treiber mehr. Sie finden ein Treiberpaket aber in den Standard-Repoistories. Sollte das nicht ausreichen, können Sie sich die Treiber für openSUSE 13.1 selbstverständlich jederzeit selbst bauen. Der Source-Code steht zum Download bereit:

[1]http://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP05/pcsc-cyberjack-3.99.5final.SP05.tar.bz2

Falls ich mal einen neuen Kartenleser benötige, werde ich diesen Service bei der Entscheidung berücksichtigen. Leider hilft mir eine unbefriedigende Antwort auch dann nicht, wenn sie schnell kommt.

Gute Nacht

Moneyplex und Card Reader nach Installation von openSUSE 13.1

Hatte jemand erwartet, dass Moneyplex unter openSuSE 13.1 nach einer Neuinstallation mit dem Kartenleser einwandfrei funktioniert?

Ja? Nicht wirklich.

Bei mir funktioniert er natürlich wieder einmal nicht. Ein Blick auf die Homepage von matrica.de offenbart immer noch das alte Märchen:

Unter openSUSE läuft moneyplex in der Regel ganz ohne Anpassungen. Wir empfehlen alle Updates und Aktualisierungen zu installieren.

Frage mich, welche Regel matrica meint. Nun gut, was soll es. Von matrica ist mal wieder keine Hilfe zu erwarten. Das Fehlerbild hatte ich allerdings schon bei der letzten Installation von openSuSE 12.3.

Abhilfe schafft diesmal der Treiber pcsc-cyberjack-3.99.5final.SP05-1.suse12.3.x86_64.rpm von den Seiten der Herstellers Reiner SCT, der allerdings nur für openSUSE 12.3 als Paket vorliegt.

sudo rpm -i --force \
     pcsc-cyberjack-3.99.5final.SP05-1.suse12.3.x86_64.rpm

OpenSuSE 13.1 unbrauchbar

Nun verwende ich schon seit Jahren die openSuSE. Natürlich gibt es immer wieder zu beginn eines neuen Release Kinderkrankheiten. Man gewöhnt sich dran und in der Regel sind sie schnell behoben. Diesmal habe mit dem Umstieg von 12.3 auf 13.1 etwas länger gezögert und zwischenzeitlich nur die KDE auf Version 4.11.x aufdatiert. Nachdem die openSuSE 13.1 in einer virtuellen Maschinen ganz zufriedenstellend lief, habe ich mich entschlossen den Sprung zur 13.1. auch auf dem Desktop zu wagen, zumal der KDE 4.11.x nicht sonderlich fehlerfrei war. Texte lassen sich in der Regel mit der Maus nicht mehr richtig markieren und kopieren. Insbesondere in Kmail erweist sich dies nahezu als unmöglich. Die Markierung verschwindet mit dem Loslassen der Maustaste auf wundersame Weise. Wenn man auf eine Symbol klickt wird die als zwei Klicks verarbeitet, was zur Folge hat, dass das Programm doppelt gestartet wird. Ein Markieren einer Mail bewirkt auch gleich das Öffnen des Anzeigefensters. Liegen zwei Fenster übereinander werden beide geschlossen. Ein Klick auch die Titelleiste des Fenstern bewirkt eine Größenänderung. Ein Verschieben erfordert sehr viele Versuche, wenn es überhaupt gelingt. Kmail2 hat auch neue Eigenheiten. Von über 1.000 Mail im SPAM Ordner werden nur die letzten angezeigt. …

Kurz: Unbrauchbar!

Adieu KDE, ich wandere zu GNOME aus.

Auch nicht viel besser. Aber hier starten wenigstens die Programme nicht doppelt. Muss ich mich jetzt von openSuSE verabschieden?

Ich fürchte, hier wird eine lang hinausgezögerte Entscheidung fällig.

Update 14.02.2014 Habe den Verursacher eingekreist und neutralisiert: Linux (was dort auch immer) mag meinen kabellosen Trackball Logitech M570 nicht. Sehr ärgerlich; jetzt muss da alte Teil wieder ran.

OpenSUSE 13.1 und Apache 2.4

Der Apache2 Version 2.4 bringt erhebliche Änderungen gegenüber der Version 2.2 mit. Den Versuch eines Updates des Apache2 auf die Version 2.4 auf einem openSUSE 12.2 System habe ich wegen zahlreicher Fehlermeldungen abgebrochen. Aus schlechten Erfahrung klug geworden, habe ich mir eine neues System von Grund auf mit openSUSE 13.1 in einer virtuellen Maschine aufgesetzt. Einen weiteren Abschuss des Servers wollte ich vor einen Upgrade nicht riskieren.

Die Konfiguration des Apache2 mit yast2 führt allerdings auch nicht zu einem lauffähigen System. Der Apache weigert sich mit mehreren Fehlermeldungen zu starten. Unter openSUSE 13.1 wird der Apache 2.4 installiert, obwohl in den Paketnamen die Version 2.2 angegeben ist. Nach einigen Versuchen konnte ich den Fehler in der Datei /etc/apache2/conf.d/mod_evasive.conf lokalisieren. Der Apache2 meldet, dass es das Modul /usr/lib24/apache2/mod_evasive20.so nicht gibt. Eine nachträgliche Installation / Update hilft nicht, denn die Datei heißt jetzt mod_evasive24.so.

Der Fehler kann nun durch Ändern der ersten Zeile in mod_evasive.conf behoben werden. Entweder wird auf das Module verzichtet und die Zeile auskommentiert / gelöscht oder der Dateinamen geändert. Eine Änderung des Modulnamen auf mod_evasive24.c führt allerdings wieder zu Fehlern.

LoadModule evasive20_module /usr/lib64/apache2/mod_evasive24.so

 
Mit einigen Hinweisen auf wirkungslose, obsolete Parameter startet der Apache2 jetzt.