Moneyplex und Card Reader nach Installation von openSUSE 13.1 (2)

Gestern habe ich über die Probleme von Moneyplex und meinem Kartenleser nach der Installation von ooenSUSE 13.1 berichtet. In einer E-Mail hatte ich REINER SCT darauf hingewiesen, dass es hier Problem gibt und das auf ihren Seiten ein aktuelles Paket für openSUSE 13.1 fehlt. Hier der Kern der Antwort, die immerhin keine 24 Stunden benötigte:

Für openSUSE bieten wir keine vorgefertigten Treiber mehr. Sie finden ein Treiberpaket aber in den Standard-Repoistories. Sollte das nicht ausreichen, können Sie sich die Treiber für openSUSE 13.1 selbstverständlich jederzeit selbst bauen. Der Source-Code steht zum Download bereit:

[1]http://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP05/pcsc-cyberjack-3.99.5final.SP05.tar.bz2

Falls ich mal einen neuen Kartenleser benötige, werde ich diesen Service bei der Entscheidung berücksichtigen. Leider hilft mir eine unbefriedigende Antwort auch dann nicht, wenn sie schnell kommt.

Gute Nacht

Update 26.07.2018

Die Kartentreiber finden sich unter „Linux-Treiber für cyberJack® RFID standard“ auf der Support Seite Reiner SCT für sehr viele, auch alte Linux Distribution sowohl für 32.Bit udn 64-Bit.

Unter Debian und Co lädt wird der Treiber ins Download Verzeichnis herunter geladen und mit folgendem Befehl installiert:

sudo apt install ./libifd-cyberjack6_3.99.5final.sp12_amd64_d09.deb

Wichtig: An „./“ erkennt apt, dass es sich um eien Datei und nicht ein Pakennamen handelt. Ohne ./… gibt es eien Fehler.

Moneyplex und Card Reader nach Installation von openSUSE 13.1

Hatte jemand erwartet, dass Moneyplex unter openSuSE 13.1 nach einer Neuinstallation mit dem Kartenleser einwandfrei funktioniert?

Ja? Nicht wirklich.

Bei mir funktioniert er natürlich wieder einmal nicht. Ein Blick auf die Homepage von matrica.de offenbart immer noch das alte Märchen:

Unter openSUSE läuft moneyplex in der Regel ganz ohne Anpassungen. Wir empfehlen alle Updates und Aktualisierungen zu installieren.

Frage mich, welche Regel matrica meint. Nun gut, was soll es. Von matrica ist mal wieder keine Hilfe zu erwarten. Das Fehlerbild hatte ich allerdings schon bei der letzten Installation von openSuSE 12.3.

Abhilfe schafft diesmal der Treiber pcsc-cyberjack-3.99.5final.SP05-1.suse12.3.x86_64.rpm von den Seiten der Herstellers Reiner SCT, der allerdings nur für openSUSE 12.3 als Paket vorliegt.

sudo rpm -i --force \
     pcsc-cyberjack-3.99.5final.SP05-1.suse12.3.x86_64.rpm

OpenSuSE 13.1 unbrauchbar

Nun verwende ich schon seit Jahren die openSuSE. Natürlich gibt es immer wieder zu beginn eines neuen Release Kinderkrankheiten. Man gewöhnt sich dran und in der Regel sind sie schnell behoben. Diesmal habe mit dem Umstieg von 12.3 auf 13.1 etwas länger gezögert und zwischenzeitlich nur die KDE auf Version 4.11.x aufdatiert. Nachdem die openSuSE 13.1 in einer virtuellen Maschinen ganz zufriedenstellend lief, habe ich mich entschlossen den Sprung zur 13.1. auch auf dem Desktop zu wagen, zumal der KDE 4.11.x nicht sonderlich fehlerfrei war. Texte lassen sich in der Regel mit der Maus nicht mehr richtig markieren und kopieren. Insbesondere in Kmail erweist sich dies nahezu als unmöglich. Die Markierung verschwindet mit dem Loslassen der Maustaste auf wundersame Weise. Wenn man auf eine Symbol klickt wird die als zwei Klicks verarbeitet, was zur Folge hat, dass das Programm doppelt gestartet wird. Ein Markieren einer Mail bewirkt auch gleich das Öffnen des Anzeigefensters. Liegen zwei Fenster übereinander werden beide geschlossen. Ein Klick auch die Titelleiste des Fenstern bewirkt eine Größenänderung. Ein Verschieben erfordert sehr viele Versuche, wenn es überhaupt gelingt. Kmail2 hat auch neue Eigenheiten. Von über 1.000 Mail im SPAM Ordner werden nur die letzten angezeigt. …

Kurz: Unbrauchbar!

Adieu KDE, ich wandere zu GNOME aus.

Auch nicht viel besser. Aber hier starten wenigstens die Programme nicht doppelt. Muss ich mich jetzt von openSuSE verabschieden?

Ich fürchte, hier wird eine lang hinausgezögerte Entscheidung fällig.

Update 14.02.2014 Habe den Verursacher eingekreist und neutralisiert: Linux (was dort auch immer) mag meinen kabellosen Trackball Logitech M570 nicht. Sehr ärgerlich; jetzt muss da alte Teil wieder ran.

OpenSUSE 13.1 und Apache 2.4

Der Apache2 Version 2.4 bringt erhebliche Änderungen gegenüber der Version 2.2 mit. Den Versuch eines Updates des Apache2 auf die Version 2.4 auf einem openSUSE 12.2 System habe ich wegen zahlreicher Fehlermeldungen abgebrochen. Aus schlechten Erfahrung klug geworden, habe ich mir eine neues System von Grund auf mit openSUSE 13.1 in einer virtuellen Maschine aufgesetzt. Einen weiteren Abschuss des Servers wollte ich vor einen Upgrade nicht riskieren.

Die Konfiguration des Apache2 mit yast2 führt allerdings auch nicht zu einem lauffähigen System. Der Apache weigert sich mit mehreren Fehlermeldungen zu starten. Unter openSUSE 13.1 wird der Apache 2.4 installiert, obwohl in den Paketnamen die Version 2.2 angegeben ist. Nach einigen Versuchen konnte ich den Fehler in der Datei /etc/apache2/conf.d/mod_evasive.conf lokalisieren. Der Apache2 meldet, dass es das Modul /usr/lib24/apache2/mod_evasive20.so nicht gibt. Eine nachträgliche Installation / Update hilft nicht, denn die Datei heißt jetzt mod_evasive24.so.

Der Fehler kann nun durch Ändern der ersten Zeile in mod_evasive.conf behoben werden. Entweder wird auf das Module verzichtet und die Zeile auskommentiert / gelöscht oder der Dateinamen geändert. Eine Änderung des Modulnamen auf mod_evasive24.c führt allerdings wieder zu Fehlern.

LoadModule evasive20_module /usr/lib64/apache2/mod_evasive24.so

 
Mit einigen Hinweisen auf wirkungslose, obsolete Parameter startet der Apache2 jetzt.

Unsere Spuren im Netz

Wo hinterlassen wir Spuren im Netz? Egal was wir tun, in dem Moment wo ein IP-Paket auf die Reise außerhalb unseres Netzes geht, entstehen Spuren unserer Aktivität und Existenz im Netz. Angefangen mit einer Anfrage an einen Domains Name Server (DNS) über das Senden einer E-Mail, über ein Herrunterladen einer Datei von einem FTP-Server bis zum Surfen im Netz immer hinterlassen wir Spuren in den Log-Dateien der beteiligten Rechner. Dies ist ein so weites Feld, dass ich mich in diesem Artikel auf die Spuren beim Surfen beschränke.

Um diesen Spuren nachzugehen, habe ich ein OpenSUSE 13.1 mit einem Firefox in einer virtuellen Maschine auf meinem Rechner installiert. Schon bei der Installtion und den Update habe ich mit zahlreichen Server im Internet Kontakt aufgenommen, die jetzt wissen, dass ich einen Rechner neu aufgesetzt habe und ein openSUSE 13.1 installiert habe. Bei einem Windows XP, Vista, 7 oder 8 wäre es nicht anders gewesen. Hier käme noch ein Anmeldung bei Mircosoft hinzu. Auch diesen Vorgang will ich nicht weiter untersuchen. In diesem Artikel will ich mich auf das Surfen mit dem Browser beschränken.
„Unsere Spuren im Netz“ weiterlesen

Angriffe auf den SSH-Port

Vor einigen Wochen hatte ich letztmalig über Angriffe auf den SSH-Port geschrieben. Die meisten Angriffe erfolgte aus dem Netz der STRATO AG. In den folgenden Tagen habe ich STRATO jeden Tag eine Mail mit den IP-Adressen der Angreifer an abuse-server ( at ) strato.de geschickt. Lange Zeit hat sich nichts getan.

„Angriffe auf den SSH-Port“ weiterlesen

Moneyplex und Chipkartenleser unter openSuSE 12.3 (gelöst)

Seit letzten Sonntag funktionierte nach einem Update das Zusammenspiel von Moneyplex und dem Kartenleser nicht mehr. Meine Versuche es mit einem anderen Repository von /security:/chipcard waren leider nicht erfolgreich. Auch ein Schwenk auf das Factory Repo half nicht. Heute hatte ich einen Mail von Jörg, mit der Lösung. Es reicht ein Downgrad von pcsc-cyberjack auf die Version 3.99.5final.SP03-6.1.1.x86_64. Diese befindet sich im openSUSE-12.3-Oss Repository.

Wenn Moneyplex nicht läuft, reichen zwei Befehle, um das Problem zu fixen:

zypper in –oldpackage pcsc-cyberjack-3.99.5final.SP03-6.1.1
rcpcscd restart

Ein anschließendes zypper ps sollte No processes using deleted files found. melden.

Herzlichen Dank für den Tipp und ein schönes Wochenende

Thomas

Update 09. Februar 2014: Siehe auch Moneyplex und Card Reader nach Installation von openSUSE 13.1. Hier hilft die Installation der Treiber und ein Downgrade auf ein Paket von REINER SCT für die openSUSE 12.3, da es noch kein Paket für die 13.1 gibt.

Angriffe auf den SSH-Port

Die ständigen Angriffe auf den Port 22 (SSH) laufen zwar alle ins Leere, aber ein Auge halte ich trotzdem drauf. Eine Auswertung des gestrigen Tages ergab, dass fast alle Angriffe (~90%) aus dem Netz von Strato kommen, wo mein Server auch gehosted ist. Hier die IP Adressen der Kameraden, die ihren Server dringend reinigen sollten.

  • 85.214.16.192
  • 85.214.16.253
  • 85.214.205.100
  • 85.214.238.63
  • 85.214.25.183
  • 85.214.253.120

Warum in die Ferne schweifen, wenn das Gute liegt so nah. Jetzt bin ich mal gespannt, ob mir Strato irgendwann auf die Meldungen antwortet.

Kmail 4.11.2: Der Inhalt des Ordners wird abgeholt Bitte warten …

Der Inhalt des Ordners wird abgeholt. Bitte warten ...
Der Inhalt des Ordners wird abgeholt. Bitte warten …

Fragt sich nur wie lange. 5 Minuten? 10 Minuten?

Ich frage mich, wie lange es noch dauert, bis KDE wieder einen stabilen Stand erreicht. Früher wurden solche Software als unstable bezeichnet. Die Zeiten scheinen vorbei.

Update 24.10.2013: Mit einigen Mühen bin ich wieder beim alten KDE 4.10.5, da ist der Fehler weg.

Moneyplex und Chipkartenleser unter openSuSE 12.3

Update 26.10.2013: Lösung siehe hier.

Der Zugriff auf die Chipkarte war nicht erfolgreich. Perform Verification: Der Chipkartenleser kann nicht angesprochen werden.
Der Zugriff auf die Chipkarte war nicht erfolgreich.
Perform Verification: Der Chipkartenleser kann nicht angesprochen werden.

Nachdem es sehr lange – für Moneyplex Zeiten – gut gegangen ist, gibt es mit dem letzten Update der Chipkartenleser Software wieder Fehler. Nur sind diese Fehler ganz anderer Art als bisher. Das System erkennt den Chipkartenleser, der Befehl cyberjack läuft ohne Fehlermeldung durch, Moneyplex erkennt den Chipkartenleser und ob eine Chipkarte eingelegt ist beim Anmelden, in den Einstellungen und der Test ist auch erfolgreich. Wenn ich für den Kontenabruf die falsche Karte einstecke, erkennt Moneyplex dies auch und fordert die richtige Karte an. Nur, wenn dann die richtige Karte im Leser steckt, dann gibt es keinen Chipkartenleser mehr.

Jetzt bin ich ratlos. Bis der Fehler gefunden ist, wird die Überweisung wohl noch ein paar Tage warten müssen. Wie immer ärgerlich.

Update 24.10.2013: Die Antwort von Matrica war wenig hilfreich. Den Dämon für den Kartenlesen habe ich mehrfach gestartet. Auch habe ich mich an die Installationsanleitung gehalten. Es lief vor dem Update. Ich fürchte, der Fehler liegt im Update des Repositories vom 20. Oktober. Leider habe ich die älteren Pakete nicht mehr. Im Moment sollte man die Finger von einem Update lassen.

Sie haben nicht das richtige Sicherheitsmedium eingelegt.
Sie haben nicht das richtige Sicherheitsmedium eingelegt.
Es befindet sich keine Chipkate im Lesegerät.
Es befindet sich keine Chipkate im Lesegerät.